How to start a new Project using the Template

How to start a new Project using the Template

This step by step guide explains how to use the Company Template to start a new project.

WARNING:

This guide requires a basic understanding of how to use Revit and AutoCAD. If you don’t have enough experience in either of these software's please request someone else to complete the model setup.

Contents


Getting Started

Step by Step Guide:

  1. Start a new project in Revit using the Company Architectural Template (there should be a link on your Revit Startup screen and in the New Project dropdown list. If not, contact the Revit Manager as your Revit has not been configured correctly)

  2. The project opens on the X00.00 – MODEL STATUS sheet as this is the Project Startup View.  On this sheet, you will see some red text notes also advising you how to get started.

  3. Perform the actions as noted in the Red Text Notes, that is:

    1. Remove the Company Symbology View and delete the Red Text Note that refers to it

    2. Remove the Company Drafting Standards View and delete the Red Text Note that refers to it

    3. Complete all the parameters on the Starting View Sheet1.

    4. Remove the remaining Red Text Notes. It should now look like this.

  4. Open the DATUM LEVEL - Working Floor Plan

  5. This view has further Red Text Note instructions on how to get started. Depending on the purpose of the file, the steps here may vary. That is, the Coordinates and True North direction only needs to be set up within the Site File. The following steps are for the Site File.

NOTES:

  1. If you are unsure how to complete a Parameter speak to the Company BIM Manager.

Site File Setup

Step by Step Guide:

  1. Before you import your Survey drawing, some clean-up work will be required. Autodesk Revit has a 20-mile sphere that you must operate within to avoid Floating Point inaccuracies. That is, if the extents of a model are larger than this, decimals on large numbers start to be truncated and you might see imported CAD lines jumping around as you zoom or pan around the view. To clean-up the Survey Drawing follow these steps:

    1. In AutoCAD, start a new file in a blank metric template.

    2. Open the original Survey file and copy all the content to the clipboard

    3. Paste into the new file at 0,0. (If you still find geometry is a long way from the origin, attempt to delete any irrelevant information by exploding any blocks that might be causing the issue)

    4. Orient the view to an Elevation to make sure there is nothing drawn at the wrong elevation that could cause the 20 mile limit to be exceeded vertically or cause incorrect topography. Correct or delete any mistakes or request a fixed file from the surveyor.

    5. Purge Unused

    6. Bind any Xref’s

    7. Delete any hatches using “Quick Select”. (Sometimes hatches come into Revit as solid black fills making it difficult to view the contents)

    8. Delete any irrelevant information

    9. Run the Overkill command to reduce the number of elements

    10. Save the new survey as “<Project Number>-Survey-Revit Import” in the appropriate folder location

  2. Import your Survey file to the DATUM LEVEL - Working Floor Plan view with the following settings1:

  3. Place the DWG file so the building will be centred at Revit’s origin.

     

  4. Set the View Orientation to “True North

  5. Identify the orientation in which you want to document the project. That is Project North.  Place a Detail Line on one of the boundaries (corner to corner) as a reference for later

  6. Rotate the Survey DWG so its orientated to how you want it to be in Project North using one of the ends of your Detail line as the Pivot Point

  7. Go to Manage Project ► Location ► Position ► Rotate True North and Rotate True North the reverse direction that you just Rotated it to.  Use your Detail Line as a reference, ensuring you use the same pivot point

  8. You can now delete your Detail Line.  With your view in True North orientation your project should now be correctly rotated.  Likewise, with your view in Project North orientation your project should still be square to the page and the Survey DWG should be rotated to suit.

    We now have True North set correctly in relation to Project North. If True North is unknown, then skip this step. The most important thing is that you document in Project North orientation, as its much more difficult to rotate Project North.

  9. The next step is to set the coordinates correctly to MGA2. Open the Original Survey Drawing (the un-edited one), in AutoCAD.

  10. ID” two corners of the site and note down the X & Y coordinates.  Remember if your survey is in Metres you will need to convert these values to Millimetres for Revit by multiplying by 1000.  We need both to ensure we have both scale and rotation accurate.

  11. Within Revit use Manage ► Project Location ► Coordinates ► Specify Coordinates at a Point, and select one of the corners you ID’d in AutoCAD.  Set the North/South value to match your DWG “Y” value and your East/West value to match your DWG “X” value.  Use ALL of the Decimals.  Don’t worry about Elevation at this point.

  12. Now run Manage ► Project Location ► Coordinates ► Specify Coordinates at a Point and select the other corner you ID’d in AutoCAD.  If your rotation and scale is correct this should now match, confirming everything is correct.  If so, select Cancel and proceed to the next step. If not, you have done something inaccurately or incorrectly - repeat steps 10-12.

  13. Open the SOUTH ELEVATION Elevation view.

  14. Select Manage ► Project Location ► Position ► Relocate this Project.  This command works just like the move command, except you don’t need to select anything.  Select Ground Level as you base and then move up or down as required so the Ground Level represents the true Ground RL you want the building to be at.

  15. If you would like the Level’s to show the true RL (AHD3), select one and right click to “Select All Instances ► In Entire Project”, then change the Level type to Xrev-Survey Point with Elevation.  You will now see the RL’s report the True AHD RL’s.  If you want them to be relative from 0, then simply use the Project Base Point versions.

  16. As the Survey Drawing is based off DATUM LEVEL, we now need to move the DATUM LEVEL vertically in the Reverse direction to the Relocate Project command to have it be at the correct RLs.4

  17. We now need to create the Topography. Switch to the {3D} View.

  18. Select Massing & Site ► Model Site ► Toposurface

  19. Select Create from Import ► Select Import Instance

  20. Select the Imported Survey File DWG in your Revit Model

  21. Select the layers that contain the contours and Select OK.5

  22. Select Finish Surface

  23. If the Survey area is much larger than the site and there are areas that aren’t required, you may need to crop the surface to a more appropriate size.  This will improve performance.  If this is not required skip to the next step.

    1. Select Massing & Site ► Modify Site ► Split Surface

    2. Select your Toposurface

    3. Draw a sketch of where you’d like to split the surface.6 

    4. Finish Edit Mode

    5. Now select and delete any unwanted portions of toposurface.

  24. To have Cut/Fill volumes calculate appropriately we need to correctly phase this toposurface. Select the Topography you just created and ensure its Phase Created is set to Existing.

  25. Copy to Clipboard and Paste Aligned ► Same Place this Topography.  This should have a Phase Created as New Construction.

  26. Select the Existing Toposurface and set its Phase Demolished to New Construction.

  27. Select Modify ► Pin this Existing topography so it cannot be edited.

  28. You would now leave the existing toposurface unedited and make any changes for the new site to the New Construction version.  Cut/Fill Volumes will automatically be calculated as a result.  If you need to reset your New Construction topography, just re-copy the existing topography and phase it appropriately.

  29. To complete our Site setup, we now need to add Property Lines for the various allotments and easements.  Select Massing & Site ► Modify Site ► Property Line

  30. You will be prompted to specify how you’d like to create the Property Lines:

    Choose Create by entering distances and bearings
    If you have distances and bearings, always use those in lieu of sketching.  This is because quite often survey drawings have the boundaries “fudged” so they form a close loop.  If this has occurred, when you tag the property line segments you will get different distances and bearings to what is shown on the survey drawing.

  31. Enter your property Deed Data as appropriate to complete the sketch.  If you are successful it will be “closed”.7

  32. Select OK when complete and closed.

  33. With the Property Line Selected, Enter the Identity Data.  The Name should be the Lot.  EG: LOT 11 or EMT A as this will be used by the Property Line Tags.

  34. It is strongly recommended to delete the 3D DWG survey from the file at this point as we now have everything we need from it.  NOTE: We will use another 2D Version of it later.

  35. OPTIONAL, if no buildings are to be modelled directly within this file, you can:

    1. Delete LevelBasement 01

    2. Delete LevelLevel 01

    3. Delete LevelLevel 02

    4. Delete LevelLevel 03

    5. Reassociated GROUND FLOOR with the Site Scope Box

    6. Delete all Grids, unless you are using a Site Grid Setup

    7. Delete all non-site related Plans/Reflected Ceiling Plans

    8. Delete all non-site related Sheets

    9. Delete the Building Scope Box

    10. Pin any remaining Grids and Levels

  36. Adjust the Site Scope box to encompass the entire site.  This controls the extents of all our Site drawings. Complete the Manage ► Project Information and Save the file using the company standard naming structure for Revit files.

  37. Congratulations, you have successfully established the basis of the site file and can proceed with setting up the building file/s. If the building occupies the entire site, then this may be the same file and you can simply continue within this file with the Building File Setup steps.

NOTES:

  1. The Import Units for Survey files are typically in Meters, but sometimes they are in Millimetres. Ensure you select the appropriate units for your Survey file. In this guide, we are going to delete this “3D” survey file later, as such we are “Importing” this version because its temporary. This is one of the few exceptions. Generally we should always “link” CAD files. If you wish to have a version underlaid in your Site Plan then “Link” a version as “Current view only” later.

  2. MGA stands for Map Grid of Australia

  3. AHD stands for Australian Height Datum

  4. If the Building RL is changed later, simply repeat steps 14-16 to move the Project and the Survey by the Relative difference.  There is no need to update any views or model elements using this method.

  5. You may need to check the DWG file or ID the layers in Revit first to ensure you know what layers to use.

  6. You cannot split the surface into more than 2 pieces at a time.  If this is required, you will need to split the surface multiple times.

  7. Sometimes you will find the bearings are entered in the wrong direction and as such you will need to add 180° to the value to have it go in the correct direction. It is always best to start at one corner and work your way around in a clockwise direction.

Building File Setup

Step by Step Guide:

  1. Switch to the GROUND FLOOR - Working View if you are not already on it.

  2. Adjust the Building Scope Box1 to suit the expected size of the building by selecting it and using the Grips.
    If you need to reduce the size of the Scope Box, you will first need to adjust the grids and elevations inwards. If they do not intersect the scope box they will lose association.

  3. Move the Grid positions and add any additional Grids required for the building, remembering that vertical grids are numbered and horizontal grids are lettered.

  4. Move the Elevations appropriately so they are not cutting through any structure.2

  5. Switch to the SOUTH ELEVATION

  6. In the Properties temporarily set the Scope Box to None and Turn the Crop Region off.  This is so we can adjust its extents and see everything.

  7. Adjust the Building Scope Box vertical extents to encompass the model extents.

  8. Adjust any Floor to Floor Heights, add any extra required levels, or remove any unneeded levels.3

  9. Reassign the Scope Box to Building and Turn the Crop Region back on.

  10. Complete the Manage ► Project Information and Save the file using the company standard naming structure for Revit files.

  11. Congratulations, you can now commence modelling your building. If Worksharing is required refer to the section on enabling Worksharing.

If you have separate building files, refer to the next section to correctly set their locations/coordinates.

NOTES:

  1. The Building Scope Box controls the extents of the Grids, Levels, and main building plans and elevations. Under no circumstance should you delete the Scope Box.

  2. When selecting an Elevation there are 2 parts. There is the tag/symbol (Elevation) and the projection plane (View). It is the projection plane that is most important to move. If you look at the status bar ensure you get the View, or better yet simply move both to keep them aligned.

  3. Do not change the elevation of Ground Level. It should always report RL 0 when set to Project Base Point.

Building File Coordinate Setup

Step by Step Guide:

  1. Open your Site File (which should have the correct coordinates set already)

  2. Before Linking, if Worksharing is enabled ensure you active Workset is appropriate. Links should be placed on their own Worksets.

  3. Link in the Building File using Insert ► Link ► Link Revit

  4. Select your Building File and use Positioning: Manual – Centre

  5. Position the building where it needs to be located on the Site both in Plan and in Elevation.

  6. Select the Linked Building and in its Properties update its Name to something more descriptive than a number.  EG: Block A

  7. Select the Shared Site ► <Not Shared> button

  8. Select Publish the current shared coordinate system to “xxx.rvt”

    If there are multiple instances of this same building first select Change… and rename or create a new Position for each location. For example, UNIT 102 and UNIT 202. This way if the link is ever removed, you will simply be able to relink with shared coordinates and specify which position you would like it to go in. Select OK once you have added all positions.

  9. Select Reconcile, you will now see the “Shared Site” parameter reports the Position Name for that link instance.

  10. Save the file.  You will be prompted to Save the new position back to the link.1

NOTE:

  1. No one can be working in the other file whilst doing this, otherwise the coordinates may be lost or disabled again. Any changes to this position in the site file will require the same Save process to update the new location and have coordinates report correctly within the building file itself.

Related articles